• Welcome to Andy's Workshop Forums. Please login or sign up.
 
October 29, 2020, 07:48:01 pm

News:

SMF - Just Installed!


Show posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - mbppg

1
Actually I found that it was my add-on SATA III controller. I had added a 6 gig PCIe four port card (2 SATA and 2 eSATA) because I wanted my SSD boot drive to be fast and at least one eSATA for my drive dock. The card even had a Marvell chipset.

But after 4 hours of playing around having issues getting windows 10 to reload, I took the card out and just used the motherboard SATA connectors and moved my five 3 TB drives over the SAS ports and bam, been working like a champ ever since. Reloaded right away, no more issues with slow choppy movements or disk reads etc. Overall running much better and more like I expect Windows to run.

The one thing I did not do was make a driver disk with the chipset drivers used during OS install but it worked fine with windows 7 and 8.1 so I thought it was not needed. Since it is working great as is, the card is not going back in. Got to say even with the SATA II it still boot pretty fast is is overall faster than windows 8.1 with the same setup. WOOHOO!.
2
So after digging into and doing some research I found that windows 10 pro was the problem. I had several BSOD, Watchdog timer errors (CPU related) and a few just simple reboots out of nowhere. I thought is was the processors overheating but I managed to catch a log file from HWmonitor in which the CPU cores where at 69 or lower when it rebooted. I have since gone back to windows 8.1 and no I have no issues, speedfan is controlling the the CPU fan correctly and no more BSOD or random reboots.

So Windows 10 is still very buggy for some systems and it seems like Xeon CPU's did not get a lot of love from Microsoft with windows 10 or they have not gotten around to fixing it yet...
3
Andy thanks for the great write-up. I was able to get my fans working as described in the write but they seem to be either full on or off but nothing in-between. The percentages on the home page jump from 50% to 100% but nothing in-between as soon as either CPU hit 50C. I have tried the same curve you had in the write and a few others but always the same result. Fans are on or off. I can manually select the speed if I deselect the automatic fan control and then set them at say 70% an the fans work. Is this a faulty motherboard fan controller?
4
Quote from: desune on March 31, 2016, 12:19:24 am
Hi mbppg,

Have you had a chance to try this yet?  Did it work?

Thanks.


Yes I did this to the cooler master fans that came with the CPU cooler and it works great.
5
Great write uo Andy, This will help people a lot to use SpeedFan with the Z800.
6
Well it has been a little while and I have been super busy. With little pockets of time I had a worked on the PC build but I did not take pictures nor did I really journal my steps. So here is the finished product. I fit an HP Z800 motherboard into a Dell Precision 690 case. So here is a short list of major issues steps:
Customized the case to fit motherboard and drive cage
Custom motherboard tray
Drilled stock motherboard CPU brackets to work with Cool Master CPU fans
Everything was off the shelf items purchased for the build.

Here are the specs/parts:
Dell Precision 690 case (free from work)
Z800 rev 3 motherboard (ebay)
(2) Xeon X5680 CPUs (ebay)
(12) 4 gig ECC samsung ram 48gig total (ebay)
MSI 4gig GTX 970 millennium gaming video card (amazon)
EVGA 850 B2 Bronze +80 power supply (amazon)
Adaptec ASR-6805 Raid controller (512 meg) (ebay)
Marvell 4 port 9200 series 6 gig SATA controller (amazon)
iStarUSA 5 bay hard drive cage (amazon)
(5) Hitachi 3.0 TB hard drives (work)
PNY 240 gig SSD boot drive (amazon)
(2) Cooler Master Hyper 212 Evo CPU coolers (amazon)
LG super blu-ray burned (amazon)
(2) Cougar 140mm PWM fans (newegg)
Couger 120mm PWM fan (microcenter)
Noctua 80mm fan (amazon)
Noctua 40mm fan (amazon)
Bulgin anti vandal switch (amazon)
Original z800 front panel connector including audio, usb and firewire cables (ebay)
Z600 power switch cable just for the temp sensor (ebay)

This PC build was fun to do and presented a few challenges but turn out to be a great setup and a great looking PC. The really cool thing is this is unique, one of a kind PC that is super fast and super quiet (no benchmarks yet). None of the high quality fans run over 20 dB but yet still move a lot of air. Just installing software and dual booting Windows 10 and Mint 17.3 Linux. Yes a havea couple cables to clean up but I wanted to get some testing completed and some software loaded first.

7
Also found a picture of the high capacity CPU fan for the z800, pin 5 is just a short jumper to ground. I have not had a chance to check it but I am pretty sure it will work and turn off the CPU fan message.
8
Update 3/3/16:

Well the idea worked...WOOHOO! I removed the 3/16 spacers and I was able to drop the new motherboard tray back down I was also able to slightly bend the rear PCI slot bracket down to match the new motherboard height. Just to be on the safe side I also used a small grinder to the hard drive cage to make sure that it was not touching the SAS port. Once I knew everything was going to fit I re-drilled new screw holes for the back bracket since it was lowered. Everything now fits!

Now the fun part, installing components and WIRING....yea...not. But I took my time to keep the wire routing clean and to allow the best air flow for the motherboard and all the parts I installed. I am still waiting for a three 140 mm Noctua case fans (two in the front and one rear) for extreme quiet and but actual real air flow. Anyway check out my progress so far: http://mbppg.com/media/PC%20Builds/Dell%20690/690%20case%20build/
9
Well I ran into an issue last night while I was installing the rest of the components into the case. While inserting the hard drive cage I noticed that it was about the hit the first SAS port on the corner of the motherboard. Let me back up here a bit. When I first started this build, I test fit everything to make sure it was going to work/fit. At the time the hard drive cage cleared the SAS port because I was using the standard 1/4 inch stand-offs for the motherboard. As the build went on I had the new custom motherboard tray installed and saw that the PCI(e) slot box (I call it that since it is removable) was too tall and not allowing the PCI cards to fully seat into the motherboard. The solution was simple, raise the entire motherboard and additional 3/16 of an inch so the PCI cards fully seat. After looking at the original motherboard tray I see that Dell used a taller stand-off than the common 1/4inch but I had forgot about the hard drive cage until last night. Normally I would just say "screw it" and just install the hard drives in the stock hard drive slots and not use the cage. I had two problems with that. One, I really wanted to use the external drive cage because it looks cool and "chicks really dig it" and and two I had already cut out the stock hard drive slots to make room for the wider motherboard.

So as I was pulling my last few hairs out of the top of my head, tired and a little frustrated, I was ready to just buy a case and be done with it. Well I got some sleep and came to work. I was speaking with a colleague of mine at work and we got to talking about my issue. Then we took a close look at the slot box and we came up with the idea to bend the slot box to drop 3/16 of an inch redrill some mounting holes. Then remove the currently 3/16 nylon bushings I have under the motherboard tray and the problem should be solved. The PCI cards should fully seat and the cage should just clear the SAS port and life will be good again. Looking at a donor case here at work I am pretty sure it can be done. I can't wait to get home and try it out. Pictures and outcome, coming soon.
10
Updated: 03/02/2016

Well I received my z800 motherboard cable and that was the last part I was waiting for. So I decided to test out the motherboard, memory and CPU I bought (all used). After checking several power supply calculators I decided to go with an EVGA 850 watt B2 +80 PSU. My total wattage including both processors, video card, hard drives and all the fans etc came out to about 630 watts. That still gives me more than a 20% buffer for in-rush power on startup and will not overload the PSU.

I first started with just one CPU which also happened to be the socket where I had to bend back a few CPU pins. And I only put in a couple sticks of RAM. Then I powered up the board and right away the CPU fan can on, a really good sign. It took about 30 seconds before I got a video screen and started going through the error it saw like date was incorrect, no rear fans, no memory fans, no front usb connections, no front sound connections etc. Good thing is no sparks, no smoke and the motherboard was mounted on the new tray.

Then I got into the BIOS screen and yes, it saw the correct CPU and amount of memory....woohoo. So I powered down the system and unplugged the PSU. Time to fully load this thing up. I installed the other CPU and fan and all the RAM, just to be safe I pulled the battery and shorted the terminals to clear the BIOS. Then I plugged in the power supply and it came to life again with the CPU fans...yes another good sign. This time it took longer before I saw the first video screen. It had me a little worried but as it counted through the errors again I was pretty sure it was going to work. The BIOS screen popped up and I hit system info....YES both CPU's reported correctly as well as the amount of RAM. One happy camper here. I set the date and time as well as the other settings, did a save and exit and now it is booting properly. Now back to the psychical hard labor....the mounting the new motherboard tray.

Pictures from the test setup: http://mbppg.com/media/PC%20Builds/Dell%20690/690%20test%20setup/

I got to looking at the stock CPU fan brackets on the underside of the motherboard and I liked the thickness and stability of them much better than the bottom brackets that come with the Cooler Master Hyper 212 Evo's. Since I had the tools an the tall nuts the come with the cool master are bigger I needed to drill the current holes on the stock brackets bigger and tap them using a 4mm x .07 tap. Once I got the holes drilled and tapped I test fit the nuts and then the top mount bracket for the CPU cooler, perfect fit. I reinstalled the brackets onto the motherboard and made sure the CPU socket covers were opening and closing correctly with no restrictions.

Back to the tray. I marked and drilled the motherboard mounting holes and marked areas to cut out below the CPU fan brackets and the chipset cooler brackets since they hang down lower than the standard ┬╝ inch bass stand-off's I was using. This also allows some air flow around the brackets from the bottom and will clear the motherboard tray without touching. I used some metal cutting hole saws to make the holes for the brackets but could also be done using a drill and a jig-saw with a metal cutting blade. Next I test fit the motherboard to make sure the riser cards would be lined up in the back and drilled a few holes to mount the motherboard tray to the bottom of the case. Then I removed the motherboard and finished drilling the rest of the holes (ten in all).

Then I test fit everything again and I found that the hight of the new motherboard tray will have to be raised by 3/16 of an inch. I noticed that the riser cards where not fully seating down and raising the tray up 3/16 of an inch would fix that problem. So I will be out later today to get ten 3/16 inch nylon spacers and ten #6-32 x 3/8 button head machine bolts to finish mounting the motherboard tray.

Pictures for tray build: http://mbppg.com/media/PC%20Builds/Dell%20690/690%20new%20tray/

P.S. Hey Andy I think I might have a fix for the 5th CPU fan pin. I will do some testing and get back with an answer in a few days.
11
I have a question along the lines of BIOS, I currently have my z800 MB running and the current version of the BIOS is 03.19 The latest version is 03.57, is there any reason not to upgrade? Current setup is two Xeon X5680 3.33 gig hex core processors and 48 gig of DDR3 1333 ECC memory.
12
Quote from: LordOdin on February 26, 2016, 08:05:28 pm
Yeah you need a UEFI bios to see over 746GB


This is not a correct statement. There are many non-UEFI BIOS's that can see and properly report hard drives larger than 2.2 TB, the issue is Windows and MBR limitation. MBR has the 2.2 TB limit and Windows cannot use GPT without UEFI but Linux can use GPT without UEFI BIOS.
13
Here are the dimensions. I did not get the CPU heatsinks or the chip-set heatsink on the bottom side but that should be pretty easy to figure out and just cut out around the entire assembly. Hope this helps.

14
Quote from: obnauticus on February 28, 2016, 03:31:58 pm
Is anyone here able to provide a dimensioned holed pattern for the Z800 motherboard? Please include/callout any CPU HS/Fan assy. holes in the drawing.

I want to figure out which server cases I can fit this thing inside of.


I still have my board out so I will try to remember to get those dimensions tonight.
15
Well after doing a little welding on the motherboard tray and looking at it a little closer I decided to scrap the stock dell tray and just make a new one. I grabbed a router blank card from work. A router card blank is a big cover with a metal back that slides into a card slot of a router so there are no holes for better cooling. The nice flat metal back was big enough to give me a 14.5 inch wide and 17 inch long piece after cutting off both ends to become a new motherboard tray. Best thing is... it cost $0.00.

I had thought about using Plexiglas for a tray but they generate static electricity and also really hold in the heat. Then I stopped at Home Depot and was looking at building/welding a aluminum tray but I remembered that the card blanks at work just might be big enough. I got lucky.

I cut the card blank down to the proper dimensions and test fit it a couple of times to determine it will work very well.

Next because one screw is close to the edge in the lower back corner, I needed to cut the case corner. On the Dell case there is a diagonal brace that runs the length of the top and bottom on both sides. By cutting the bracket this allowed me to move the motherboard mounting screw a little closer to the bottom of the case to better line up the line cards on the motherboard with the case alignment slots for the PCI and PCIe slots.

Next I needed to get the motherboard mounting holes marked, drilled and tapped for the motherboard mounting screws. I had some motherboard screws left over from other PC builds that have the 6-32 screw threads on the bottom and the 6-32 coupler on top. They allow the motherboard to stand off the motherboard tray approximately .250 inches.

The next step is to mark and drill holes to mount the tray to the side of the case. I plan on using very low button head screws for any holes under the motherboard so they sit low enough to not touch any of the motherboard wire leads poking though on the underside of the motherboard. Also there was enough room and use a couple of the previous motherboard tray holes around  the outside of the mounted motherboard. I did all this reverifying the alignment of the PCI/PCIe slots with the back plate slots before drilling holes to make sure it was going to work. One thing, even though the Dell case is big, I ended up losing the last motherboard PCIe slot as I did not want to rework the case back slots to move it over one to be able to use all the motherboard slots. Which is okay since I did not plan on using that one anyway. Drill pictures coming later.

Pictures from todays work: http://mbppg.com/media/PC%20Builds/Dell%20690/690%20case%20cut/