• Welcome to Andy's Workshop Forums. Please login or sign up.
 
December 06, 2019, 08:12:59 am

News:

SMF - Just Installed!


An easy to build android/bluetooth reflow controller

Started by Andy Brown, July 12, 2015, 03:53:12 am

Previous topic - Next topic

DeNew Lab

March 30, 2017, 03:59:26 pm #30 Last Edit: March 31, 2017, 07:02:57 am by DeNew Lab
Thank you.
I'll try later SSR.
SSR HSR-2D302R (no ZeroCross Switching)
Z - Zero Cross Switching
R - Random Switching


Quartz heaters did not like the long heating.

A new project, halogen lamps 10ps. of 1500W, consistently 2 pieces.
I bought a toaster oven ))

DeNew Lab

The first check of the stove.
Thermoprofile is excellent.
The result. 12 lamps of 1500 watts. 3 connected in series.
Sorry for the mess ... :-[

https://www.youtube.com/watch?v=A_tCNhYqNXg&feature=youtu.be


Andy Brown

Your oven is super-accurate throughout the whole profile, better than I've ever achieved and I thought mine was good. I particularly like the way that yours heats from the top and bottom at the same time. Best reflow oven I've ever seen, well done!
It's worse than that, it's physics Jim!

davek

Hi Andy,
Just wanted to check this topic was still live as there hasn't been any posts for a while 

Andy Brown

Hi Dave, yes I'm here. If you have any questions please ask.
It's worse than that, it's physics Jim!

kellogs

Hello,

Great project, just what I needed!

Is it supposed to start the heaters if commanded so from the rotary encoder ? It has never been linked to a bluetooth device and it is running off the internal 8Mhz RC for the moment.

Thank you

Andy Brown

Hi, yes it will do that. Bluetooth is not required to run a reflow.
It's worse than that, it's physics Jim!

kellogs

Alright, I'll be needing some help please.

Checked with a DMM (steady 0V, no fluctuations) and the MCU is not driving the transistor -> optocoupler -> ultimately triac. Of the top of my head MCU should drive the triac if
- asked to do so from rot_enc;
- it has proper zero cross detection (checked with logic analyzer; it does)
- it has proper SPI comm and good type K thermocouple & wiring

The SPI is good (LCD is functional) + checked for continuity on all 3 wires (MAX31855 <-> MCU). Now about this thermocouple.... ebayer sold it to me as type K but from what I gather it should have had a magnetized cathode, which it does not - i.e. neither of it stwo wires will stick to a magnet. Maybe it ain't a K-type TC and that's what bothers the whole system ?
I seldom see any temperature on the LCD as the screen is covered by "Err 2 No link or similar, but I have seen 27, 0, and 55 degrees C on it, and I think nothing else. Checked with DMM for voltage and the the TC does respond with some milliVolts upon heating thoroughly and some 1-2 minutes latency (from time of heater switch off to actually seeing it decrease in voltage). Tomorrow I shall get my hands on a new TC, hopefully of K type and report back. If any hints please share,

Thank you!

kellogs

I have now put in the 8 MHz crystal and got bluetooth working. Also got a second thermocouple; they both seem to have the same problem "gnd short". Checked for T+ / T- for shorts to GND; nothing came up. The resistance between T+ and T- I have found to be 11 ohm if it is of any importance. For brief moments there actually is a temperature reading on Android if I fiddle with the connector lugs. Most of the times I fiddle with them and still just "gnd short". Any clues ?

Thank you

kellogs

Ok, fixed that one. It was an error in my electrical scheme. I have got temperature, what I haven't got is power on the oven terminals. Reflow session begins and 0V reads over those terminals. When I take out the oven wires from the oven PCB terminal block I can read 135 - 140V in or out of reflow session. The oven works fine when applying power directly over its wires, and the logic side driving the MOC3020 also appears to work (i.e. checked for voltage on the Q1's collector: it is 83 mV, so it is saturated). Now what ? ...

kellogs

Now just swap the connections between A1 and A2 pins of the triac and it will work. Not recommended though, I have ended up with these very close wire-to-pin cases. So it kind of works, aside from three times smoking, the strange noises, and huge initial latency my quartz oven has. It comes up to speed afterwards, I guess I'll have to tweak the PID. And the everything else.

HDRW

Hi Andy, I'm new here, having seen one of "your" reflow boards demonstrated at the Newbury Radio Rally yesterday.  Very impressive!
I'd like to have a go at building one, but at the moment I don't have the time (I'm retired, so have no time to spare!  :-)

I did notice one thing in the video, though:  it looks like you're using an IEC *input* (C14, plug) for the connection to the oven, when it should be an output (C13, socket) - otherwise you could have unshielded pins with live mains on.  Or is it an oprical illusion in the video?

73,

Howard  G1BYY

Andy Brown

Hi Howard, yes you are right I used the wrong gender connector there and didn't warn others not to do the same.
It's worse than that, it's physics Jim!

_jp

Hi Andy/Everyone

Thanks for posting so many articles, it really helps newbies like me getting started in electronics hardware projects.

I'm using KiCad and I can load up the the gerber files ok, but I would like to play with the schematic.
Is it permissible (or even possible) to get a copy of the reflow project so I can load the schematic into KiCad?

Also, I really like your process controller articles. Nice one.

JP


Andy Brown

Hi, I see that there's a script available that converts Altium to KiCad. I'll run it on the schematic at the weekend and if it works then I'll provide the results.
It's worse than that, it's physics Jim!